Scheduled for February 01, 2025 at 10:20 PM – 10:50 PM
Affects
Website
Under maintenance from 10:20 PM to 10:50 PM
Redot Proposal Viewer
Under maintenance from 10:20 PM to 10:50 PM
Updates
Completed
February 01, 2025 at 10:50 PM
Completed
February 01, 2025 at 10:50 PM
Maintenance has completed successfully
In progress
February 01, 2025 at 10:20 PM
In progress
February 01, 2025 at 10:20 PM
Maintenance is now in progress
Planned
February 01, 2025 at 10:20 PM
Planned
February 01, 2025 at 10:20 PM
The Redot Proposal Viewer will be undergoing migration to a new website. During this time, the viewer will be temporarily unavailable. We appreciate your patience and understanding. Stay tuned for updates!